[Information] Adding "-Dfml.readTimeout=60" as java argument

Discussion in 'Wiki' started by Babymillie, Jan 28, 2018.

  1. Babymillie

    Babymillie SrAdmin Staff Member SrAdmin Spectre

    Dec 5, 2017
    Likes Received:
    24/7 Lazy guy
    So i'm going to try my best to explain here, i'm not as good as our expert sliki guy :)

    So if you are unable to join the server and its giving you a timeout connecting, one thing you can try is adding -"Dfml.readTimeout=60" as a java argument to do this its not really hard.

    Launch the launcher, when the launcher is open click on the ☰ on top right,
    then you will see "News" "Skins" "Settings" "Launch options" , click the last one "Launch options"
    you should now see 2 options below example "FTB Revelation" and "Latest release" ,
    ignore latest release and click on "FTB Revelation" (or any other modpack you launch the game for skyfactory/beyond/etc..)
    You now should see allot of options ignore most of them unless you know what you are doing, and go straight to "JVM arguments"
    you will see it being enabled (if not do so) and text in there is something in the line of
    (scroll to the right to see more)
    -Xmx12288m -Xms256m -XX:PermSize=256m -Dminecraft.applet.TargetDirectory="C:\Users\<user>\Documents\Curse\Minecraft\Instances\FTB Revelation" -Dfml.ignorePatchDiscrepancies=true -Dfml.ignoreInvalidMinecraftCertificates=true -Duser.language=en -Duser.country=US
    So when you see this go to the last character in that line in my case "US" add a space behind US and type in " -Dfml.readTimeout=60"

    the final line would be something like (do not copy this)
    (scroll to the right to see more)
    -Xmx12288m -Xms256m -XX:PermSize=256m -Dminecraft.applet.TargetDirectory="C:\Users\<user>\Documents\Curse\Minecraft\Instances\FTB Revelation" -Dfml.ignorePatchDiscrepancies=true -Dfml.ignoreInvalidMinecraftCertificates=true -Duser.language=en -Duser.country=US -Dfml.readTimeout=60
    then click the green button "Save" then go back to "News" and hit play

    this may work or may not work for you

    If you have changed MC settings to use latest java on your pc, you wont have that launcher screen but a different one but its pretty much the same except when you have launcher open click on the bottom left on "Edit Profile" and at bottom of that screen you will see "JVM arguments", add the option there

Share This Page